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A little about me...

BSME NC State University 1994

Married 23 years to Jennifer. We
have two daughters, Rachel and
Rebecca

Work Experience

1994-95 Nortel Operations

1995-97 Nortel Mfg. Engineer
1997-98 Nortel Mechanical Engineer
1998-06 Solectron Mech. Engineer
2006-2012 IBM Mechanical Engineer
2012-14 I1BM Windchill/Creo Admin
2014- Lenovo Windchill/Creo, ...

Assembly Process Plan

| first started using Assembly
Process Plan module in 1996 while
working as a manufacturing
engineer at Nortel




About Lenovo

Lenovo (HKSE: 992) (ADR: LNVGY)is a
US$43 billion global Fortune 500 company
and aleader in providing innovative
consumer, commercial, and data center
technology. Our portfolio of high-quality,
secure products and services covers PCs

(including the legendary Think and
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multimode Yoga brands), workstations,
servers, storage, networking, software
(including ThinkSystem and ThinkAgile

solutions), smart TVs and a family of mobile

products like smartphones (including the

Motorola brand), tablets and apps.




Assembly Process Plan

Used to create assembly process plans and
serviceability documentation. A process plan
allows:

— Steps of an assembly fabrication process
or a disassembly process

— Manufacturing BOM for each step

— Regroup components independent of the
design assembly to accurately model the
fabrication structure

— Assemble tools and processes unique to
a process step without affecting the
design assembly

— Perform time and cost estimates for the
assembly fabrication process.

— Detailed drawing views for each step

— Customize the display of each process
step by defining multiple explode states
and by assigning different colors and line
styles to components based on their

status in the step
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When to use Pro/Process?

- If an assembly requires three or more steps
to properly explain the assembly process

* Desire to have multiple BOM tables with
uniqgue BOM balloons for each step on
drawing

* If you need to document the assembly steps
prior to creating 2d assembly drawing

* Need to add tools and fixtures to the
assembly models

* Need flexibility to create unique simplified
reps, explode states, etc. without impacting
design assembly
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Accessing Assembly Process

» Must be using license with Advanced
Assembly Extension (AAX)
(e.g. PROE_EngineerllAAX)

* New

— Click File > New. Inthe New dialog box, click
Assembly and Process Plan. Lenovo names the
file using the base name of the design assembly
and a suffix of “-000”

(e.g. sm17a12345-000.asm)

* Existing

— Click File > Open and select an existing assembly
process file
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Add Process Status to model tree to identify
components needing to be assembled

* To display process status in the model tree,
click Settings > Tree Columns above the
model tree. Select Process Status from the
Type Info list and click Add button. Click
OK

* To display process steps in the model tree,
click Settings > Tree Filters above the
model tree. Check the box next to Features
in the Display list
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Creating First Step

* Click ASM PROCESS > Sequence > New
Step

* Choose the type from the STEP TYPE
menu: Assemble, Disassemble,
Reassemble, Reposition, or General. Click
Done. (Assemble is most often used)

» Select Add Model from COMP SEL menu,
Std Comp from PRS COMP TYP menu,
Open from GET MODEL menu and navigate
to desired assembly model. Click Open




= Creating First Step (continued)

Elernent Info
Components Defining =
Description Optional
Simplfd Rep Optional
Explode State Mo Explode
View Optional -

IC » Select dialog becomes active after clicking
Refs | | _ofo Open in previous step

Cancel Preview

» Unassembled models are displayed with
phantom lines by default

Add Model
Done » Select the components to assemble from the

Quit model tree or onscreen and click OK
w PRS COMP TYP

Fab Unit » Components being assembled will be shown
Bl tem in current display style by default

Teoling

Select x




Step Description

File Edit

Assemble bracket to stiffener using M3x10 screws
Torque to 1.5 N-m

View Name: | [MEEI]OII s

@ Saved Orientations

Standard Orientation
Default Orientation

MName:

Delete
Orientation | Perspective
Type: | Orient by reference

Reference One: | Front

&

Reference Two:

Simp Rep

MNew

Na
Default Rep

View Manager

Appearance

Edit -

mes

=% Master Rep

Automatic Rep

© Options -

Exploded Views

Explode | Appearance

MNew

MNames
No Explode

Edit -

: % Default Explode

Properties > =

© Options ~

STEP: Assemble

Element
Components
Description
Simplfd Rep
Explode State
View

Time Estimate
Cost Estimate

Infao

Defined

Assernble bracket to stiffener
Defined

DEFALLT EXPLODE

Default

Value = 0.100000 HOURS
Value = 2.000000

Refs

Cancel

Creating First Step (continued)

* Define the following optional elements
— Description
— Simplified Rep
— Explode State
—View
— Time Estimate
— Cost Estimate

* Click OK when done

It is recommended to name Simplified Rep, Explode
State and View using current step number (e.g. STEP1)
for easier use in the detail drawing. A combined state

may also be helpful.
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Menu Manager

Fab Unit

Play Steps
Integrate
STEPSEQUENCE

Copy
Delete
Suppress
Resume
Step Library
Group
Redefine
Reorder
Insert Mode

Done/Return

Creating Next Steps

* Click ASM PROCESS > Sequence > New
Step

 Select components and define optional
elements as required for the new assembly
step
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Select Step Menu Manager

p ASM PROCESS

Menu Manager

Play Steps/Process Display

: STEP 1: Assemble

Sequence
STEP 2: Assemnble

Fab Unit

Play Steps 7
w STEP REGEM
Set Step
PreviousStep
Mext Step

Integrate
w STEP REGEM

* Click ASM PROCESS > Play Steps > Set

Set Step Info Step
PreviousStep Done
Mext Step

Info
Done

 Select Step and click OK

| Info | | QK | | Cancel |

* Click Next Step and Previous Step to play

20 ANBHD T o - -Lle-R@RELDIT -3 = 4|08 steps forward and backwards

File Model Analysis Annotate Tools View Applications
g Nbeer  @salioid QAT - S e - Select Process Display from the Model tab
- l Suppress ¥ ¢r Activate i) UDF Operations = | &3 Process Sequence | (J Repeat
R t
ege:era : f Edit Definition .J_) Replace ) Group DI Mirrer Component
Operations | Process Plan | Component
gﬂ Model Tree --' Folder Browser _il Favorites Process Display
Model Tree T& ¥ Assign display states to use when selecting

. compeonents for a process plan.
-

Process Component Display X

Process display Selection display

Previous components: | Transparent Shaded |v|| Current Envirenment |'|

Current components: | Current Environment "” Current Environment |"

Unused components: | Blank ‘v” Phantorm |v‘

| Minimize repaints || Reset to default |

Ok | Cancel |
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New Drawing

Process Drawing

Default Model
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=m17a00301.asm Browse...

Sketch
Part Specify Template

Assemnbly ® Usetemplate * ACtlvate deSIQn assembly mOdel

O Empty with format

Manufecturing O Empy (not the assembly process model)

Drawing

E Qe

=

Template
Format ;

Motebook

OC®O00C0O0

[ b3 bl

oo « Click File > New > Drawing. Uncheck Use

al_drawing

a2 drawing default template, enter a Name and click

a3_drawing

Marne: | demo-assy 34_drawing OK

Commen name: a_dram‘ng
b_drawing

c_drawing

[ Use default template d_drawing

e draving » Select Use Template and click the template
named assy-process_4q2015. Click OK

OK Cancel
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ﬁ _-| Mew Sheet _FH [%] Import Drawing/Data Q @ . ’ Del Model

£ Sheet Setup [ Object o
Lock View mages Drawing General FReplace et Mode

Movement '3 Move or Copy Sheets i3 Copy from Other Drawing | Models | View View Model o -
Eemove Rep

Document Set/Add Rep Next, let's add the assembly process model

Eﬂ Model Tree H"j Folder Brows... Hﬂ Favorites

Replace
Muodel Disp
Done/Return

4 Drawing Models

¥ Drawing Tree Manage drawing models.

* Click Drawing Models from the Layout tab

- | '|D * In Session v|t"| ‘SEEFCh---

D ———— _ » Select model and click Open

Common Folders (i 5m17a00301-000.asm
[T In Session [CJ sm17a00301.asm

I Desitop S, S - Select State, Simplified representation,
sm27a prt =5 = .
£3 My Documens " and Explode state. Click OK

=] mbohannen-16gm0 State:

~¥ Working Directory STEP 1: Assemble
‘&| Manikin Library STEP 2: Assemble

% | Favorites

‘EJ Network File name: =m17a00301-000.asn Preview =

File name: | sm17a00301-000.as ZI Sub-type -
s foltr e -

Simplified representation:

| Master Rep

Explode state:
| Default

| OK || Cancel |
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Layout Table Annotate Sketch Legacy Migration

S Somegn |y I8 Process Drawing (continued)

- [

[ sheet Setup [ object
Lock View Images ) Drawing| General Feplace
Movement ') Move or Copy Sheets 3 Copy from Other Drawing || Models | Wiew View Model

Document ‘ Insert ~

Bo ModelTree | 2 FolierBrows. | o) Fovris ) Draing Mods * Click General View from Layout tab and
Tommtes - add view to sheet

Drawing View

R — » Select Combined State if used and click OK

View Type
Visible Area Mo Combined State
Scale

Sections

(i S  Elodevien » Modify Drawing View properties as required

View Display Explode components in view
Origin
Alignment Assembly explode state | Custom

Customize Explode State | ° MOdlfy Process D|Sp|ay as dESWGd

Simplified representation

Simplified representation | Master Rep |v|

Component Step Display x
Line Font Color
Process step
Previous components|§ Default |v| .
Process assembly step | STEP 1: Assemble |v |

Current components | Default |'| IIl

|E O AN0AE-HD o o v§§|@ & E L&D~ 52 4| - DEMO-ASSY (Active) - Creo Parametric

Layout Table Annotate Sketch Legacy Migration Analysis Review Tools View Framework

B [ New Sheet |—_I£;j Import Drawing/Data — @ _lrjl Eu Projection View == Revolved View g Component Display 7] Hatch/Fill @ Erase view %

- — ) =

e [ Sheet Setup E Object e 8 Detailed View % Copy and Align View ||(C]] Edge Display & Convert to Draft Group | [&] Resume View
Lock View Images Drawing General Replace . Tex
Movement (L1 Move or Copy Sheets 73 Copy from Other Drawing | Models  View  View Model :@ Auxiliary View ;ﬂ Drawing View 00 Arrows 3] Move to Sheet £ Show Modified Edges Styl

Document | Insert ~ Model Views = | Edit ~ | Display ~ |
- - I 1 I 1 I B il I 1 I
§ﬂ Model Tree ‘-J Folder Brows... | _# | Favorites {o#] Process Display I::,. 0, |
¥ | Show Paths

¥ Drawing Tree hd
Sheet 2 of DEMO-ASSY.DRW

@ new_view_13

[o#| Process Display

Medify the display of process assemblies in
drawing views.

\\“L Erase Paths
9 | Convert to Draft Entities
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g*ﬂ Model Tree _1‘ Folder Brows... _il Favorites — R Column Model/Re
== Repeat Region P
] — ) o ) Attributes
¥ Drawing Tree ﬁ - Define a repeat region in a table, edit a repeat
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Flat/Rec [tem

[=] Sheet 2 of SM17AD0301.DRW
- Filters

Sort Regions

Comments
Indentation
Dash [tem
Fix Index
Summation
Relations
Update Tables

+ ~|[Z] ¥ InSession v |t¥]|Search... Switch Syms
Y MSs

W Organize v £ Views v T'f Tools v Lo Done

Common Folders : L] sm17a00301-000.asm |

[ In Session ] sm17a00301.asm

[ Desktop [ sm27a00366.prt

[ sm2Ta00434.prt Process State

f=l My Documents

=] mbohannon-16gm0 State:

Process Drawing (continued)

Update table repeat region to use correct
process step

* Click Repeat Region from Table tab. Select
the region.

» Select State, Simplified representation,
and Explode state. Click OK

'_|+ Working Directory

| STEP 1: Assemble

‘& Manikin Library STEP 2 Assemble

(% | Favorites

File name: sr17a00301-000.asm Date modified: Preview ~

‘|i| Metwork
File name: | sm17a00301-000.asm Type| All Files (*) -

» Folder Tree

Cancel

Simplified representation:
Master Rep

Explode state:
Default

I I SMZTRDG3RE BRACKET. CAGE POCWER SUPFLY
ITEM| GTY PART MNUMBER: DESCRIPTICN

PARTS LIST FOR STEP 1

Cancel
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We should be glad of an opportunity to serve others by
any invention of ours; and this we should do freely and
generously.”
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ONLINE HELP

http://support.ptc.com/help//creo_hc/creo30 pma_hc/usascii/index.html#page/assembly/processassembly/Assembly Process Planning Overview.html

e @ http://support.ptc.com/help//cren_he/cren30_pma_hc/usasciifindexhtml#pac 2 ~ & 2 PLM Report System & Search Result e Creo Help Center X
File Edit View Favorites Tools Help
7 1) Open APIs - Creating pers... O SharePoint 2013 Pass Para... O SharePoint 2013 Pass Para... @ survey Mon-IT Managed ... @& Create Safe & Secure Pass... e DCG EC Services @ DCG Windchill

_ A Assembly Process Planning > Assembly Process Planning Overview

= -
Infroduction E .
What's New Creo 4.0

Assembly Process Planning Overview

Creo Tutorials
Fundamentals

The Assembly Process Planning Help describes the procedure of creating assembly process plans and
Model-Based Definition

service documentation. It offers information about capturing each step of the manufacturing process,

Data Management . . . . . . -
and saving them in a uniform and accessible format. Refer to these help topics for information on

using the Process Assembly environments, tools, and techniques. For a detailed overview, skim the

Part Modeling Help contents.

Data Exchange

Detailed Drawings

L Basic Tasks for Process Assembly
ayout

+
+
+
+
+
+
+ Design Exploration
+
+
+
+
+ Surfacing * Working with Models
+ Rendering .
— Assembly Design * Defining Steps
+ Assembly Design * Generating Bills of Material

+ Creo Intelligent Fastener * Defining Fabrication Units

- A bly Process Plannii * Using Simple Representations
Assembly Process Planning * Creating Drawings
Overview

+ Assembly Process Planning
Configuration Options

+ Assembly Process Planning
Basics

+ Creating Process Steps

+ Creating SimpReps, UDFs and
BOMs

+ Creating Fabrication Units

+ Creating Views, Drawings and
Reports

+ Info and File Export
+ Creo Product Insight Extension

+ Advanced Framework Design v

Lenovo.



http://support.ptc.com/help/creo_hc/creo30_pma_hc/usascii/index.html#page/assembly/processassembly/Assembly_Process_Planning_Overview.html

Pro/Report Parameters P ocuen

iprs.actstep. comp.name Displays the names of all assembly components in the active step.
&Drs.aCTStep. COMD.DETEM.Name Displays the names of all parameters for each assembly component in the active
step.

iprs.actstep. comp.param. value Displays the values of all parameters for each assembly component in the active

http://support.ptc.com/help//creo_hc/creo30 pma_hc/usascii/index step
.html#page/assembly/processassembly/AboutObjectParametersin

iprs.actstep. comp.type Displays the method of assembly for each component in the active step.
Drawings.html ]

iprs.actstep.comp.User Displays the values of any user defined parameters for each assembly

Defined component in the active step.

iprs.actstep. comp.desc Displays the descriptive phrase of the active step.

iprs.actstep.name Displays the name of the active step

&prs.actstep. number Displays the active step number.

&prs.actstep.param.name Displays the names of all parameters associated with the current assembly
maodel.

&pra.actstep.param.value Displays the values of all parameters associated with the current assembly
model.

iprs.actstep. type Displays the names of all parameters associated with the active step.

&prs.actstep.User Defined Displays the values of any user defined parameters in the active steps.

Lprs.step.comp.name Displays the names of all components for each step displayed in the drawing.

§prs.step.comp.param.nams Displays the mames of all parameters of each assembly component for each step

in the drawing.

&prs.step.comp.param.value Displays the values of all parameters of each assembly component for each step
displayed in the drawinag.

&prs.step.comp.type Displays the type of component being assembled for each step displayed in the
drawing.
&prs.step.comp.User Defined Displays the values of any user defined parameters for every assembly

component displayed in the drawing.

&prs.step._desc Displays the descriptive phrase of each step shown in the drawing. d

&prs.step.name Displays the mame of each step shown in the drawing. >

&prs.step.number Displays the step numbers of every step in the drawing. o

&pES.Step.param.name Displays the names of all parameters associated with the steps displayed in the :
drawing. &

&pra.step.param.valus Displays the values of all parameters associated with the steps displayed in the I
drawing.

iprs.step.type Displays the methods of assembly used for each step displayed in the drawing.



http://support.ptc.com/help/creo_hc/creo30_pma_hc/usascii/index.html#page/assembly/processassembly/AboutObjectParametersInDrawings.html

Configuration Options for Assembly Process Planning

curr proc comp def color

Sets the default color for the current component in a process assembly.

curr proc comp def font

Sets the default font for the current component in a process assembly.

display comps to assemble

yes, no

ves— The design model goes into memory and displays. Pick process components from the design model or the Model Tree.

no—0Only the Model Tree displays components to assemble. Selected components go into memory.

offset line def color

Sets the color of offset lines in drawings.

offset line def font

Sets the offset line fonts in drawings.

prev_proc comp def color

Sets the default color of components added to a process assembly in a previous step.

prev_proc comp def font

Sets the default font of process assembly components that were added in a previous step.

Related Topics

About Assembly Process Planning Configuration Options
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